Wolcen: Lords of Mayhem – Launch of to DirectX 9

Wolcen Lords of Mayhem - Launch of to DirectX 9

Starting Wolcen: Lords of Mayhem on video cards supporting DirectX 9
 
The system requirements Wolcen: Lords of Mayhem indicated that it is necessary to run DX11, but the game can be run on DirectX 9.
Especially for this purpose there is a patch, it will launch Wolcen: Lords of Mayhem on video cards supporting DirectX 9.
 
Installation: Install the game folder

Download:DirectX.Patch.Wolcen: Lords of Mayhem

P.S. The patch works on steam and pirated versions Wolcen: Lords of Mayhem

Leave a Reply