Overload Playable Teaser – Launch of to DirectX 9

Overload Playable Teaser - Launch of to DirectX 9

Launch Overload Playable Teaser on video cards supporting DirectX 9
 
Developers Overload Playable Teaser indicated that it is necessary to run DX11, but the game can be run on DirectX 9.
Gamers have already made a patch, which will start the Overload Playable Teaser on video cards supporting DirectX 9.
 
Installation: Install the game folder

Download:DirectX.Patch.Overload Playable Teaser

P.S. The patch works on steam and pirated versions Overload Playable Teaser

Leave a Reply